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Flash® has long been used as a tool to create animation,

rich-graphics and interactivitiy on the Web. It’s often

used in the development of e-Learning, but usually by

Flash gurus steeped in ActionScript, under the direction of

instructional designers. The learning curve has always been

steep and the use of Flash by the average online course

developer or instructional designer has been rare.

With Flash MX, and particularly with
Macromedia’s latest release of that tool,
Flash MX 2004, this has changed.
Macromedia realized that they have a
potential base of users (read customers)
that they could leverage if only they could
make the product a little easier for 
e-Learning developers further down 
the food chain to use. Flash MX 2004
attempts to do just that — make the
development of e-Learning in Flash sim-
pler, more intuitive and more accessible to
the e-Learning course developer masses.

Macromedia has achieved this by
adding some new features, such as tem-
plates and components that can be used
as the building blocks of e-Learning. The
most interesting of these additions are
forms-based authoring, learning interac-

tions, user interface (UI) components 
and quiz templates.

The new features in Flash
This article is primarily a step-by-step

tutorial to show you how to create 
e-Learning content with the new Macro-
media Flash MX 2004. I will briefly
address some of the new features and
then dive into a “how-to” for a small
Flash e-Learning demo. The demo is not
designed to be an example of either a
complete e-Learning project or a demon-
stration of great instructional design. It’s
meant to quickly show you some features
of Flash MX 2004 that allow it to be
used by a non-expert to create some
impressive, interactive e-Learning.  

Continued on next page
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The latest version of

Flash MX has been

specifically designed

for the instructional

designer or subject

matter expert who

has no experience

with Flash or with

ActionScript. Here 

is a fast tutorial 

that will introduce

you to the main 

features so that 

you can start using

this tool in your 

e-Learning projects

right away!



Forms-based authoring
One of the challenging aspects of

learning Flash has been gaining an
understanding of how to use timelines,
frames and keyframes. Macromedia has
now introduced a forms-based metaphor
that allows you to design content on
forms and then to move between these
forms. (Figure 1, right, shows a simple
forms heirarchy.) With the use of built-
in slide show templates, this can be
likened to creating e-Learning content in
a PowerPoint presentation and moving
between slides.  This is by far my fav-
orite feature — I find it so much easier
to think in terms of moving between 
content in forms, rather than figuring 
out the change of content over time.

The learning interactions
In previous versions of Flash you could

create questions, quizzes, drag and drop
interactivity, embedded video, etc. How-
ever, because doing these things was
somewhat complex and a little painful for
the newbie user like you and me, Flash
gurus were usually brought in to code
that kind of work.  The good news with
this latest version of Flash is that Macro-
media has created a library of learning
interactions so that you can drag and
drop one of them on the stage (the work-
ing area), configure the interactions and
text you want, and bingo it’s done. (Fig-
ure 2, below, shows an example of the
stage (on the right) and a learning inter-
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FIGURE 1 Forms-based authoring

FIGURE 2 Using learning interactions
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action instruction set (on the left).)
The interactions include Drag and

Drop, Fill in the Blank, Hot Objects, Hot
Spots, Multiple Choice questions, and
True or False questions. In five minutes
you can develop interactivity that previ-
ously would have taken you hours, even
if you knew what you were doing.

The UI components 
The last of what I think of as the new

“big three” elements are the UI compo-
nents which are basically an easy way to
add advanced functionality to a Flash
project. You can drag and drop compo-
nents such as buttons, check boxes,
combo boxes, radio buttons, menu bars,
and many more right onto the stage and
very easily configure them and add
behaviors. (Figure 3, right, shows a 
list of user interface components.)

Quiz templates
These are templates provided by

Macromedia that allow you to create and
configure six different types of quiz ques-
tions. (See Figure 4, below.) You can use
this template to create any type of inter-
active quiz or test you wish and automat-
ically get a score calculated and dis-
played. (I haven’t included the quiz tem-
plates in the demo but you can find
them under File > New > Templates.)

SCORM and AICC 
All the learning templates and learning

objects that are created in Flash MX
2004 allow for out-of-the-box
SCORM/AICC compati-
bility for use within an
LMS. If you need more
information on this or
on any of the learning
interactions, take a 
look at the PDF at:
http://www.macrome-
dia. com/support/
flash/applications/
learning_interactions/

What you’ll need to create the 
e-Learning demo

First you’ll need to download Flash MX
2004 Professional at http://www.macro-
media.com/software/flash/ and click on
“Try” Flash MX 2004 Professional. You’ll
get a 30-day trial. (Editor’s Note: These
are very large files, and you can expect it
to take several hours to download them
if you are on a dial-up connection.)

Then, go to www.fhoton.com/
FlashDemo and download the Flash-
Demo.zip file. This file includes all the
content you’ll need to build the demo.
Take a look at eLearnDemo1.swf — it’s
the final result you are going to create in
this tutorial. 

Next, if you are a complete beginner
with Flash, you need to spend a little
time playing around and getting used to
some of the basic menus, ideas and ter-
minology. At the first URL listed above
you can choose the “How do I use Flash
MX 2004?” link. It’s quite long but you
can fast forward to the basic menus and
user interface section. I also recommend
that you familiarize yourself with Flash
Help in case you need it. (And here’s a
tip — use the <Ctrl> key and the mouse
scroll button to increase the size of the
Help text. The default size can give you a
headache.)

If you have already used Flash at least
once or twice before then I would move
right along to the tutorial that starts on
page 4. FIGURE 3 The new UI components

FIGURE 4 Quiz templates



Step-by-step tutorial
This should take you about 60 to 90

minutes to create once you have down-
loaded and installed Flash on your sys-
tem.

The “Introduction to Doggies” 
e-Learning demo

A. Setting up the slides 

The first step is to set up the movie file
and the slides.

1 Choose File > New > Templates.
Choose Slide Presentations from the
Category list and select the “Sharp
Presentation” template.

You can zoom in and out with Ctrl + or
- or choose the drop-down at top right
to adjust the zoom percentage.  Fit in
Frame is a good one to use.

Notice the forms/slides-based
metaphor here. 

Take a minute to check out the
screens on the left-hand side panel.
Click on them and take a look. Notice
the outline structure of the screens,
the hierarchy.  

Any nested screen inherits the charac-
teristics of its parent.  Any child
screen under the “contentHeader”
screen will have the content appear.
In this case the “My Company” header
will be present on all the child screens
below.  You can think of this screen as
being similar to the slide master in
Microsoft PowerPoint.

2 Go ahead and delete all the screens
below the contentHeader screen.
(Multiple select with <Ctrl hold> and
press delete.)

These are just sample screens with
content that Macromedia provides.

3 With the contentHeader screen selected
right-click and choose Insert Nested
Screen. 

A new slide named slide1 should
appear.  If it is not labeled slide1 sim-
ply double-click on its name and
rename it to slide1.

4 Highlight this new slide1, right-click and
then choose Insert Screen.  Insert eight
more screens.

We don’t want to nest under slide1 —
we want them all at the same level.
You should end up with slide1 thru
slide9. 

5 Save your Flash file (.fla extension) and
call it e-LearningDemo.

The working Flash files are .fla files
and the exported (compiled) Flash files
are .swf files.

6 Select the Title slide and change the
title to “Introduction to Doggies” and
add two doggie-related subtitles.

Use the Text Tool to select a text box
and then edit the text.  Change font
size if you wish by selecting text and
then clicking the font size drop-down in
the Properties panel at the bottom.

To de-select any text in a text box
press the <Esc> key.  The text box will
then have a blue outline.  The arrow
keys can then be used to move and
fine-tune the position of the text box. 

If you wish to add any graphics to this
or any screen choose File > Import.

7 Select each of the large square brack-
ets with the Selection Tool and delete
them.

Keep them if you wish, but I feel it
looks cleaner without them.

8 Select the contentHeader slide and
change the title at top left to
“Introduction to Doggies.”

Get rid of the brackets if you feel
inclined to. 

9 Select the presentation slide, select the
two “previous” and “next” icons and
move them off to the bottom right of
the brown footer.

Notice when you move elements on
the stage that alignment guidelines
appear to make sure that the ele-
ments are aligned correctly.  Nifty, eh?

10 Let’s test the “movie” now by choos-
ing Control > Test Movie.  When the
movie screen appears click on the
“next” button and make sure it takes
you to the next slide.

You can also use the keyboard short-
cut <Ctrl> <Enter>.

11 Close this preview screen.

Right-click on tab or the close window
icon top right.

B. Adding basic content 

Ok, now we will add content to each of
the slides.

1 Select slide1.

2 Open the Word file DemoContent and
select the text and graphic “Making
People Happy” on page 1 of the docu-
ment.

This is in the zip file you downloaded.

3 Copy the text and graphic from Word
and paste onto slide1 in Flash.  Align
as necessary.

You can right-click the slide in Flash
and choose Paste.

I have provided content in this form in
Word to save time writing and format-
ting text in Flash, as well as importing
graphics.  If you feel inclined to write
your own text, use the Text Tool.  I
have provided all the doggie graphics
in .gif form should you wish to import
them individually.

When importing graphics and other
media you are given a choice to
Import to Stage or Import to Library.
Import to Library should be used if you
wish to use the media elements more
than once in your project. You can
then drag and drop them from the
Library panel onto the stage. 

4 Select slide2.

5 Copy and paste the contents of page 2
of the Word document onto the slide as
outlined above.

6 Select slide3.

7 Copy and paste the contents of page 3
of the Word document onto the slide. 

8 Go ahead and test the movie with
<Ctrl><Enter>.

Navigate through the pages and check
out your work.  Cool, eh? 

9 Leave slide4 blank for now.  We will
return to this later and add content.
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C. Add a drag and drop quiz slide

In this step, we will use one of the learn-
ing interactions to create a simple quiz.

1 Select slide5.

2 Use the Text Tool to add a title: “Test
your Doggie Knowledge” and a subtitle:
“Answer the questions on the following
pages to see how much you have
learned.”

This is a title page to introduce the fol-
lowing quiz slides.  Choose appropri-
ate font sizes. 

3 Select slide6.

4 From the Flash drop-down menu choose
Window > Other Panels > Common
Libraries > Learning Interactions.

The learning interactions panel with its
associated assets will appear on the
right.

5 Drag and drop the “Drag and Drop”
asset onto the slide.

You’ll see a large rectangular frame
and a smaller rectangular frame with
instructions in it. 

6 Center the larger rectangular frame on
the slide.

The smaller rectangle with the instruc-
tions on it will not appear when the
movie is run.

7 Select the Drag 1 element and delete it.

You may need to click or double click a
few times to select the element.
Make sure you select the whole ele-
ment and delete it all. We will replace
this element with a doggie jpeg.  

8 Choose File > Import > Import to Stage
and choose the dachshund.jpg image.

This is one of the unzipped files in
your Demo directory.  (You could
choose Import to Library if you think
you will use these images more than
once.

9 Place the dachshund graphic where the
Drag 1 element was.

10 With the dachshund selected choose
Modify > Convert to Symbol.  Give it

the name “Dog1” and the behavior
“Movie clip”.

A symbol is a Flash reusable object.
Repeated instances of symbols do
not increase the file size.

11 In the Properties panel below the
stage, click where it says <Instance
name> and type in “Dog1”.

You need an instance name for the
symbol to be able to refer to it.

12 Now scroll to the left — off the slide
so you can see the Drag and Drop
Interaction rectangular frame.

13 Select this and you should see a
Launch Component Inspector button in
the Properties panel.

14 Click this Launch Component
Inspector button.

The Component Inspector panel will
appear.  This will allow you to config-
ure the Learning Interaction compo-
nent.

15 Choose the Parameter tab and change
the first Drag Object Name 
to “Dog1”.

This is the instance name of the
dachshund graphic symbol. 

16 Close the Component Inspector 
window.

17 Now repeat the whole process again
from step 7 above for each of the dog-
gie jpegs.

The same process but using the
names Dog2, Dog3 and Dog4 for the
Borzoi, Chihuahua and Italian
Greyhound.

18 When you have repeated the process
for all doggie jpegs change the wording
of the question as needed.

Something like, “Drag each doggie to
the correct target.”

19 Test the movie with <Ctrl> <Enter>

Navigate to the appropriate slide,
“drag-and-drop” and click “Check
Answer.”  If you have problems, care-
fully check your symbol and instance
names and the names within the
Component Inspector window.

D. Add a multiple choice quiz 

Now that you have an idea of how to use
a learning interaction, creating a multiple
choice quiz should be straightforward.

1 Select slide7.

2 Drag-and-drop the “Multiple Choice”
Learning Interaction asset onto the
slide and position it.

This is the same idea as the Drag and
Drop asset.

3 Select the smaller rectangular frame
and press the Launch Component
Inspector button.

4 Under the Parameter tab add your dog-
gie question and add possible answers
in the Label column.

Something like, “Which are character-
istics of the Borzoi?” and give five
possible answers.

5 Click the check boxes to denote correct
answers.

6 Close the Component Inspector panel
and test the movie with <Ctrl> <Enter>.

Navigate to the appropriate slide and
test the multiple choice question.

E. Add a fill in the blank quiz slide 

Again, this is very straightforward and
uses another learning interaction.

1 Select slide8.

2 Drag and drop the Fill in the Blank
Learning Interaction asset onto the
slide and position it appropriately.

3 Select the smaller rectangular frame
and press the Launch Component
Inspector button.

4 Add a question and the correct possible
responses.

5 Check the correct box alongside the cor-
rect answers.

6 Close the Component Inspector panel
and test the movie with <Ctrl> <Enter>.

Getting the idea?  Pretty cool eh?  (If
you feel like it you can add extra
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slides later and play around with the
Hot Objects, Hot Spots and True or
False learning interactions.) 

F. Add hyperlink to a website 

We will add content for a final slide and
create a link to a website.

1 Select slide9.

2 Copy the text and graphic on page 4 of
the Word file and paste into slide9.
Align as necessary.

3 Carefully select the last line of the text
— “Dog Breed Info Center” with the
text tool.

You may need to click or double-click a
few times to select just this text.

4 Make sure the Properties panel is
expanded to show the URL link entry
box.

This can be done by clicking the down
arrow, at bottom right on the
Properties panel.

5 Type in the complete URL
“http://www.dogbreedinfo.com”

6 Test the movie and see if the link is
working. <Ctrl> <Enter>

G. Embed Flash demos in Flash 

It is often useful to be able to include a
tool simulation within an e-Learning pro-
gram to show the learner how to use a
piece of software.  We will use a short
Flash simulation demo that was created
with RoboDemo©.

1 Go back and select slide4.

2 Choose File > Import > Import to
Library and select the Doggie.swf file.

This is the short Flash tool simulation
created with RoboDemo.

3 Drag and drop the Doggie.swf file from
the library onto slide4 and position it
centrally.

Choose Window > Library if the panel
is not showing.
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4 Test the movie.

You should see a Flash simulation running
when you navigate to slide4.

Audio and video
Adding audio narrative and embedding

video clips is also straightforward.  It’s just a
question of importing them to the stage or
library and using them like any other asset.
Take a look at VideoClip.fla for an example of
adding a video clip to a slide.

Closing
I hope this has given you a taste of how it’s

possible to use Flash for some e-Learning
projects without needing to bring in the “Flash
heavies.”  If you want highly sophisticated
Flash interactions in your e-Learning, and you
need to tie in with your LMS, then there’s no
substitute for using Flash experts who live
and breathe timelines and ActionScript.  If
your needs are less demanding, then hopeful-
ly this tutorial will have given you the confi-
dence to create some of your own Flash-
based e-Learning and realize it’s not as scary
as you once thought.
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